webworks@canadaweb.net  403-291-9811 or 866-291-3857

WordPress Web Hosting

If you are still shopping around for your hosting you just need to keep in mind the requirements for running WordPress. Thankfully WordPress has very simple requirements and will run on just about any standard linux based hosting service. Indeed a hosting company would be mad not to support WordPress given it is used on around 20% of all websites. That said, it pays to be aware of the specific requirements, namely:

  • PHP version 5.2.4 (or higher)
  • MySQL version 5.9 (or higher)

And that’s it! If you have these two then the latest version of WordPress will run great. Any web server that supports PHP and MySQL is good, but our recommendation is always to seek out a host that uses the Apache web server, and specifically can enable the Apache mod_rewrite module as you will need this to enable the friendly URL features of WordPress. As long as you use a reputable and experienced web hosting company like CanadaWeb Inc.  then the chances are that this will be the case. If you are unsure we suggest asking us if they do enable the mod_rewrite module in Apache by default before signing up. We recommend you use hosts like CanadaWeb Inc. that run Apache only because along with Linux, PHP and MySQL It really is the most commonly used platform so you can always find people who can help either professionally or via the WordPress support forums.

CanadaWeb Inc. (operator of the WordPressCanada.ca website) uses high performance, dedicated LiquidWeb servers for hosting client websites.  We have had outstanding results with their servers as well as the excellent 24/7/365 support.

 

WordPress Hosting - Servers

WordPress Hosting – Servers